Error: PutConvertWorkbook. Exception: Unable to read beyond the end of the stream


I’m getting this error message, but no idea about what it means.

Could someone please help me debugging it?

Thanks in advance,


Please post detailed information here. We will check it ASAP.

I’m at the mobile now. Tried to open API usage to share more details, but getting this error
Screenshot_2023-07-21-09-57-27-578_org.mozilla.firefox.jpg (134,8,KB)

My app is called GDrive x ZRecruit Hub
And the error message is complete in the beginning of the topic.

Are there other information I can provide?


This error is usually caused by incomplete network transfers, can you tell me the size and format of the processing file?
It would be useful to provide sample files so we can reproduce this error.

Here is one sample file:

It isn’t a so big file.


Thank you for your provided file. We check it ASAP.

We ran several tests and converted the file to multiple formats, but we were unable to reproduce the issue you were experiencing. Can you tell us about your operating environment? We will test again.

The last attempts are just ignoring parameters I’m giving.
I’m sending format and the file, but my usage logs only showing ‘no input’.

I’m sending request from Zoho Creator. Can I provide you more information about my operating environment?

Are you using the Cells Cloud API on the Zoho Creator platform?
I recommend that you first test the conversion API using the Cells Cloud SDKs on a local server or computer.

It is possible that there are call limits on the Zoho Creator platform.

I use Zoho Creator for a long time, and I’m sure that we are not running a call limit issue. What other causes can we be facing?

How it works to get 1-to-1 support until get this issue solved?


Please provide the email address of your account using the API.
we will check it in the cloud system logs.

Truly appreciate if you can get accurate information in the logs, because we need to sort this out with some urgency

Thanks in advance

We found seven records related to your mailbox in the system log. We checked these logs and found that when there are format and checkExcelRestriction parameters, the conversion API can run normally.
We will test again based on these log information.
In addition, I suggest you take two tests:

  1. Try other formats;
  2. Continue to try the parameters that work properly in the log: format=xml&checkExcelRestriction=true

Now that we’ve reproduced the corresponding error.
We created a new ticket about the issue. And we will solve it ASAP.

ok, I wait for your response and appreciate the urgency :slight_smile:

We have opened the following new ticket(s) in our internal issue tracking system and will deliver their fixes according to the terms mentioned in Free Support Policies.

Issue ID(s): CELLSCLOUD-12277

You can obtain Paid Support Services if you need support on a priority basis, along with the direct access to our Paid Support management team.


We have released Aspose.Cells Cloud 23.7. Please give it a try.

Hi @wangtao, I’ve just tried it again and just the same response:


"RequestId": "533e0c42-de61-4600-9feb-43580727169f",

"Error": {

    "Code": "internalError",

    "Message": "Unable to read beyond the end of the stream.",

    "Description": "Operation Failed. Internal error.",

    "DateTime": "2023-08-02T16:14:47.3137109Z"



Could you please check?


We have examined the system log using the request-id and found some information about the request.

Currently, the convert API does not support the file query parameter.

Could you please post the Excel file here? We will check it ASAP.