Aspose Cloud Storage AWS S3 Error

Attempting to read internal storage results in an 301.
Ex: curl -v "

“AmazonS3 Storage exception: The bucket you are attempting to access must be addressed using the specified endpoint. Please send all future requests to this endpoint.”,
“Operation Failed. Exception of type ‘Amazon.Runtime.Internal.HttpErrorResponseException’ was thrown.”

1 Like


We are sorry for the inconvenience. We are investigating the issue and will update you soon.

1 Like

Yup. We’re experiencing this issue too. We’ve been unable to use the system for a COUPLE OF DAYS and it’s unacceptable. We are also encountering time outs. This is now a major production outage for us and yet your status page shows no outages!

@tilal.ahmad Is there any update on this? We need a resolution ASAP. You’re a service provider who isn’t currently capable of providing a service to us.

We have opened the following new ticket(s) in our internal issue tracking system and will deliver their fixes according to the terms mentioned in Free Support Policies.

Issue ID(s): STORAGE-166

You can obtain Paid Support Services if you need support on a priority basis, along with the direct access to our Paid Support management team.


We are truly sorry for the inconvenience. We are looking into the issue with high priority and will share an update shortly.

@tilal.ahmad - When do we think that normal service will be restored?

We’re facing same issue for all our customers where we integrated this API… it already starts last Thursday with some timeouts and outage…
Why is it not transparently communicated in status page? Status -

I hope you understand that this issue is really critical and it is irrelevant if it’s reported by Free or Paid support since it’s influencing our paid subscription and this is an outage of your productive API where file upload to storage is probably the most core functionality. We use this service for several productive environments of our customers and need some clarification to communicate.

image.png (11.3 KB)

@colinkoffie, @MikeAshtonAJB, @UPGSALES

We identified a problem causing this timeout/storage issue and fixed it now. Can you please Aspose.Words Cloud service and share the result.

@tilal.ahmad Thanks for that. Yes the service seems to be working normally now.

There are still no incidents listed on your status page though. May I politely enquire whether it’s ever updated? We constantly have issues with the service timing out (we always have) and they never show on here.

Do you have automated monitoring in place?

How did the increased memory usage not raise an alert?

How would you typically communicate issues like this?

@tilal.ahmad - OK, we are still experiencing timeout issues. A call to upload a 25k file just timed out after a minute. So it looks like Aspose is back to functioning as it always has :frowning: (i.e. intermittently broken)

I can’t see the exact response that you’re providing but it looks like you’re timing out after 60 seconds (this is usually 100 seconds btw) and then your sending back HTML where we were expecting JSON

This is the error that we’re seeing “Unexpected token < in JSON at position 0”.


Actually, at the moment, the timeout errors are not logged because another node has automatically started. In reference to the automated monitoring question, yes, we already have a policy in place. However, we are actively monitoring the logs and working to improve the service response.

Seems storage works correctly at this time, so for us it’s now working again. Thanks for fixing!

An input for optimization:
Is it possible for Aspose.Words API calls to respond with an error http status instead of 200 OK when there is an error in background (i.e. in case of this "errorAmazonS3Storage)? So for example, when the file isn’t uploaded effectively it should not response with status 200… then we can stop further executions basing on these files if it went wrong.

Unfortunately it’s not working again. Seems again to stuck in timeouts…
Error 502 when uploading files to storage:
image.png (17.1 KB)


We have increased the number of server nodes for Aspose.Words Cloud. We are observing the situation closely and will add more hardware as required.


Time outs are the major issue for us. Does this mean that it’s difficult for you to see the number of timeouts that occur?

@tilal.ahmad We are still seeing timeouts. Here are the response times that we record for the various API calls. You can see that at 8:05 we are still encountering timeouts (they are typically shown in this graph by a response time of 100 seconds, although yesterday we were seeing timeouts at 60 seconds).
image.png (24.0 KB)

The following graph shows the response times over the last 2 months. You can see that we have historically had a lot of timeouts (both at 100 seconds and at 60 seconds)… especially recently
image.png (77.9 KB)

What can you do to resolve this?


We have made some changes to our API and hopefully they will improve the timeout issues. Please try now and let us know if you still face any such issues.

Hi @tilal.ahmad, the situation does seem a little better now but I will continue to monitor it.

What have you changed? And is this a permanent change?


Yes, it is a permanent change; we made some updates to dependencies in the submodules.