We're sorry AsposeCloud doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.cloud

Zapier - Merge file output file not supplied

I am using Aspose with Zapier to merge two or more docx files together.
The function works well however once the merge step in the zap has completed the output doesn’t contain the url to the file. This means I can’t make use of this file in the next step.

The only output i get is as follows:
file: (Exists but not shown)
filename: MergedByAspose.docx

I have setup aspose to use Internal Storage with my Zapier application. Perhaps using a different storage option will provide the URL in the output.

@lbernardza

We are looking into your query and will update you soon.

@lbernardza

I am afraid Aspose.Words Actions does not provide the output file URL but save it to storage and return the file name. You may configure your Google Drive storage with Aspose Cloud account and set it as default storage. And use one more google drive action to get URL. Hopefully, it will help you to accomplish the task.

Your suggestion makes sense. I tried to implement this but now I keep getting this error when connecting my Aspose account to zapier. I tried creating a new application on Aspose but that also causes an error.

We hit an error adding your new account

authentication failed: Unexpected error: 400. { “Error”: { “Code”: “error”, “Message”: “Object reference not set to an instance of an object.”, “Description”: “Operation Failed. General Error.” }, “RequestId”: “Root=1-612c914b-403f2bc31988a618355e5ed2” }

@lbernardza

Please double check you are passing the correct Client ID and Client Secret. You test quickly the authentication issue using authorize tab from aspose.cloud API reference.

i doubled checked the credentials and even created a new app.
I tested the credentials using the api tester you provided and it works 100% but doesn’t work with zapier; perhaps there is an issue with the zapier connection?

does it matter what storage the application is using. I tried two apps. One app has local storage; the other has Google Drive storage? The local storage did connect to zapier after multiple attempts but not the other application.

@lbernardza

We are sorry for the inconvenience. Yes, it seems Google drive storage associated with aspsoe.cloud account is not working as expected. I have changed my aspose.cloud account default storage from aspose storage to Google drive storage. My existing zap was working fine with Google drive but until I reconnect the Aspose connection in Zapier, I start getting your reported issue. We are investigating the issue(WORDSMARKETPLACEAPP-48) and will share our findings with you soon.

Meanwhile, you may use Google drive Upload File action event to upload the output file to Google drive.

thanks for this. The example you sent works for the input of the files but not to get the output.
I will wait for feedback re the zapier connectivity with Google Drive as the storage option.

@lbernardza

We will appreciate it if you please elaborate a bit more. In the above example, we showed how you can upload the result(output) of an action (in this case merge action) to google drive.

my mistake - the solution you shared works as expected. Thanks.

1 Like