Free Support Forum -

Word Document Mail Merge feature of Aspose.Words Cloud API throwing Internal Server Error

I’ve created a private topic with the details, but we checked this further, and it seems that the problem is on the server side, because we checked this with data that worked previously and now does not work any more.

This is urgent, please check this ASAP.


Thanks for your inquiry. We have checked the logs and noticed that you are using v3 API version so getting the issue. Please note it is not a stable version. Please use stable version v2, it will resolve the issue and will give you the consistent results. We have also shared API version information in our public documentation:

Hi @tilal.ahmad,

We don’t want to use the stable, we want to use the frozen version in our customers sites.
I don’t understand why we need to move them to v2, when we moved them to v3 according to aspose personal recommendation.
In addition, I tried using the v2 api and got: Status=Unauthorized, StatusCode=401
Are you going to resolve the issue on the v3 version?



Thanks for your feedback.

Yes, we have fixed the issue on v3 version.

We are sorry for your inconvenience. We will further look into it and will guide you accordingly.

@tilal.ahmad so the issue is resolved? Can we tell our customers that they can use it again?


Yes, the reported issue is resolved. You may ask you customers to resume work.


I doubt there would be some misunderstanding to recommend the use of v3 frozen version. Can you please point me to the related conversation/thread? So we will be in good position to guide you.

Please note v3 version is frozen and planned to use for a new microservice architecture. It will be public in the near future. We will announce it with complete details before launching. It will have a lot of differences and improvements.

So for now, please use v2 stable version or v1 if you want to get updates frequently.

We have tested your sample files with v2 API version and unable to notice any issue. Please double it, If the issue persists, then please share your sample code here. We will look into it and will guide you accordingly.