Free Support Forum -

Validating OMR template using Aspose.OMR REST API is throwing Bad Request error

I am attempting to test out your platform by generating a template using your Aspose.OMR.Client tool. After marking up an image, when attempting to validate the template, a 400 bad request is thrown during the validation process (the file upload of the source image completes successfully)

In my aspose dashboard, the error response is:

Error: An error occured while connecting [A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond]. Method: Run specific OMR task. Parameters: name ‘omitted.png’,actionName ‘CorrectTemplate’,param ‘Aspose.Omr.Cloud.DTO.OMRFunctionParam’,storage ‘’,folder ‘’

I have also tried the request directly from the Ruby SDK and get the same response when following the steps in the demo file.

The IP listed is not my IP, so I assume it is a server IP. Please advise whether this is a platform issue or if something wrong with the payload.


Thanks for your inquiry. We are looking into the issue and will update you shortly.


We are sorry for your inconvenience. We have investigated the logs and there was an issue with the servers for a while. It should work now.

I just tried validating again, and got the same error as before.


We are investigating the issue and will get back to you soon.


We are sorry for the inconvenience. We have fixed the production server and it is working now.