We're sorry AsposeCloud doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.cloud

PPTX to HTML5 Conversion Issue - Parameter Is Not Valid

I’m currently testing aspose.slides capabilities using the supplied cloud docker image.

When I try to convert a pptx to html, everything seems to work fine.
When I used the exact same curl to convert to html5 instead, I get the following error:

{
  "requestId": "3a41cad4-0b29-4c2a-9344-0a10b5c58cce",
  "error": {
    "code": "internalError",
    "message": "Parameter is not valid.",
    "description": "Operation Failed. Internal error.",
    "dateTime": "2022-05-17T15:58:51.9296345Z"
  }
}

I’ve tried pointing the curl to the non-self-hosted cloud API and I get the same error.
This is the curl cmd I’m using;

curl -X POST 
	"http://localhost:3030/v3.0/slides/convert/html5" 
	-F "file=@test.pptx"  
	-H "accept: multipart/form-data" 
	-o "testoutput.html"

@totoguy,
Thank you for contacting support.

Please try using cURL parameters for the PPTX to HTML5 conversion as shown in this article:

If the issue persists, please share the presentation file you used.

I get the same results using the parameters in the example (which amount to mostly using --data-binary to supply the file, instead of -F “file=…”.

I cannot supply the pptx here at the moment as it may contain some sensitive data, but I’ll try to sanitize the data and reproduce the issue.
I did try some other pptx files, some seem to convert and some cause a similar but more detailed error - “SolidFillColor is unavailable for FillType=Picture” (see attachment).
test3.pptx.zip (396.2 KB)

@totoguy,
Please share the cURL command that raises the error you described when using the presentation you provided.

curl -X POST "https://api.aspose.cloud/v3.0/slides/convert/html5" 
 -H "Content-Type: application/octet-stream" 
 -H "accept: multipart/form-data" 
 --data-binary @test3.pptx 
 -o output.html

@totoguy,
Thank you for the additional information. I’ve reproduced the problem with converting the presentation to an HTML5 document and added a ticket with ID SLIDESCLOUD-1464 to our issue tracking system. Our development team will investigate this case. You will be notified when the issue is resolved.

It would be great if you could also provide additional data to reproduce the error you described in the first message.

While trying to produce a pptx without sensitive data that causes the same error, I managed to get the original presentation to convert to HTML5 after removing some slides.

But it seems that even when it works, there are a lot of issues with graphics and shapes (some images are missing, some shapes are stretched out over several slides, etc).

I’ve attached samples to reproduce the issues I mentioned, but I think I will give up on this feature for now. I’m looking for a solution that can be production-ready in a few weeks, and the PPTX->HTML5 feature of your product doesn’t seem to be at that state, I’m afraid. Even if you somehow fix everything for the next release (22.6), it sounds like it will take months for that version to become available in the self hosted docker I plan on using.

Thank you for the help though.
Archive.zip (170.8 KB)

@totoguy,
Thank you for the additional data and testing. We will do our best to improve HTML5 export. With the presentations you provided, I also logged the following problems found:

  • SLIDESCLOUD-1468 (PPTX to HTML5 conversion raises error “Parameter is not valid”)
  • SLIDESCLOUD-1469 (Text font is changed when converting PPTX to HTML5)
  • SLIDESCLOUD-1470 (Image is missing when converting PPTX to HTML5)
  • SLIDESCLOUD-1471 (Line spacing is changed when converting PPTX to HTML5)
  • SLIDESCLOUD-1472 (Slide notes are missing when converting PPTX to HTML5)
  • SLIDESCLOUD-1473 (Position of shapes is changed when converting PPTX to HTML5)
  • SLIDESCLOUD-1474 (Text wrapping is incorrect when converting PPTX to HTML5)

Our development team will investigate these cases. You will be notified when the issues are resolved.