We're sorry AsposeCloud doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.cloud

Post to https://api.aspose.cloud/connect/token with invalid data does not return

When sending the POST request to https://api.aspose.cloud/connect/token with missing or just slightly wrong client_id or client_secret, the request does not get answered but remains stuck without an answer. At least, the request should get a 400 status code back

To reproduce, run the following curl command:

curl -X POST "https://api.aspose.cloud/connect/token" -H "Content-Type: application/x-www-form-urlencoded" -H "Accept: application/json" -d "grant_type=client_credentials&client_id=abc&client_secret=def"

This call never ends…

@nimagnaag

We are sorry for the inconvenience. Yes, I have noticed the problem. We are investigating the issue and will fix it soon.

1 Like

Any update on this? We have issues with certain clients getting the authentication token. Even though the application uses the same information, the authentication request is not returning on some clients (repeatedly) while it works on other clients.

As long as the request is not returning (with an informative error code), we can’t figure out what’s wrong because the application is stalled.

@nimagnaag

Thanks for your patience. We have redeployed our credentials server and now it is working as expected. Please double check and let us know.

@tilal.ahmad - thanks a lot and I can confirm that all problems are resolved now. :grinning: :+1:
I don’t know what changed exactly but it was really weird. While sending the same request using curl worked fine, it didn’t return when sending the same request from our application. Of course, we have to assume that the request was not exactly the same. And it worked for some clients while others failed… :thinking:
Anyways, thanks again for helping out!

1 Like