Free Support Forum -

OAuth 2 Authentication token issuance from Aspose REST API throws error: Unsupported_grant_type

Hi all
We are trying to set up the oAuth connection to Aspose.clouds but we keep getting this error message


We are using “grant_type”: “client_credentials” in our request (which is what the documentation says) so why would we be getting this error message?



Thank you for contacting us.

Following cURL and Postman example should help you in identifying if you are setting any Header or Body parameter wrong:

cURL example to get Access Token
curl -v “
-d ‘grant_type=client_credentials&client_id=0B17F60A-6D69-426B-9ABD-79F35A6E9F7B&client_secret=53b8b19adffa41a3e87dbbd8858977ae’
-H “Content-Type: application/x-www-form-urlencoded”
-H “Accept: application/json”

Postman Example

Yes, I am using all those details. You can see the API request using all those example credentials here

And I am getting the same error,



Post Data field is containing data in incorrect format. Please replace the following data:


with following:


Please note the ampersand (&) sign and equal (=) operator.

Request in API Tester will look as follows:

We hope this helps!

Thanks. That worked perfectly.
Thank you for your quick replies.

1 Like


Please note now Aspose Cloud APIs start a support of JSON Web Token(JWT) authentication as well. New API Versions of Aspose Cloud only support JWT authentication. However, old API Versions continue to support OAuth 2.0.