Free Support Forum - aspose.cloud

Merge Slides -- Ruby

Hi,


I am getting an error when I try to merge powerpoint sides. Here is the error:

/R&D/abose/PPT/lib/aspose_slides_cloud/api_client.rb:48:in `call_api': Not Found (AsposeSlidesCloud::ApiError)

from /R&D/abose/PPT/lib/aspose_slides_cloud/api/slides_api.rb:847:in `post_presentation_merge'

from merge.rb:23:in `'


And this is the code:

#require 'aspose_slides_cloud'
require_relative 'lib/aspose_slides_cloud'
include AsposeSlidesCloud
include AsposeStorageCloud



app_sid = "Xxxxxxxxxx"
app_key = "xxxxxxxxxxxx"

#Get App key and App SID from https://cloud.aspose.com
AsposeStorageCloud::AsposeApp.app_key_and_sid(app_key, app_sid)

@slides_api = AsposeSlidesCloud::SlidesApi.new

file_name = "sample.pptx"
merge_file_name_1 = "welcome.pptx"
merge_file_name_2 = "demo.pptx"

merge_request = PresentationsMergeRequest.new
merge_request.presentation_paths = [merge_file_name_1, merge_file_name_2]

response = @slides_api.post_presentation_merge(file_name, merge_request)

Hi,


Thank you for your interest in Aspose.Slides.

I have observed your comments and like to request you to please create two presentation files named welcome.pptx and demo.pptx as input files because they are being used by the code over this link. Or you may download the files from this link. Make sure you get your App key and App SID from this link. There is no problem while merging the presentations. I request you to please try using Aspose.Slides for Cloud 1.5.0 which is the latest available version, at the moment.

Please let us know if the issue persists. We will be glad to help you further.

Best Regards,