Free Support Forum - aspose.cloud

Manipulating PowerPoint Presentation Error using Aspose.Slides Cloud API

When using the Aspose.Slides for Cloud REST API (v1.1) and calling the Slides resource, I receive a status 500 error response with the message “An error has occurred.” on certain files.


I’ve attached an example file that causes the error. It contains 5 slides.

I’m confident the problem is file-specific and not the API request itself.

curl ‘https://api.aspose.cloud/v1.1/slides/.../slides?folder=…&storage=s3&appSID=…&signature=…’

’…’ represents actual data that I have removed due to security.

What’s odd is that If I remove any one of the 5 slides, upload to s3, generate URL, etc. and call the Slides resource for the new file, the request succeeds.

I understand that you want to rule out user error, but I can assure you that this call works with other files stored in the same s3 bucket using the same logic for signature generation, etc.

Please help.

Thanks,

-Geoff

Hi Geoff,


Thank you for posting.

I have observed your comments and worked with the file shared by you. I have not been able to reproduce the issue. Firstly, I tried uploading the file but the gateway timeout happened and file did not upload since the file is a big one. I uploaded the file manually over this link and then tried to execute the code shared by you but of no use. Are you able to upload the file over the same link and facing the issue while calling slide resource? Please explain when does this error appear. Please share complete code sample except the App SID and App Key and the steps to reproduce the issue, so that we may investigate it further to help you out.

Best Regards,