We're sorry AsposeCloud doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.cloud

Is There an Issue with the Cloud Slides API?

Code that has been working for years is now hanging waiting for a response.

I’m getting inconsistent results on my calls. Sometime they respond as normal, other times they just hang – no response. With debug turned on, I can see the PUT and the Body, but I never get a response back (nor I timeout).

Looking the API Usage log, I can see the previous call but not the one that is hung.

Suggestions?

More info —

It looks like the calls are getting queued and are taking a very long time to get processed. After waiting a very long time, I finally got a 504 timeout error:

[504] Server error: POST https://api.aspose.cloud/v3.0/slides/output_2021-11-24_19-23-35_u619ed7871ec4a.pptx/replaceText?oldValue=%25%25Meeting_date&newValue=Test+meeting&folder=finalDecks&storage=emiaws resulted in a 504 Gateway Time-out response:

Looking at the API Usage log, it looks like some of the calls eventually get processed, but it’s taking many hours before they get processed.

It looks like the failing call doesn’t get logged.

@klubar,
Thank you for contacting support.

To investigate this case on our end, please share “output_2021-11-24_19-23-35_u619ed7871ec4a.pptx” file that you used. If you have used PHP in doing so, please share a code example reproducing the timeout.

These are files that we’ve used for years without any problem. At your suggestion, I’ve updated to the new SDK (21) for php. This still hasn’t fixed the problem.

Could you PLEASE investigate if there is an issue at your end? It seems like existing code has stopped working, and the behavior is inconsistent – sometime the code works and sometime the exact same code doesn’t.

Any chance that it’s a problem with one of the two servers? Re-running the same sequence sometime works, but not consistently and the code hangs up on random calls (sometimes works, sometimes doesn’t).

servers
54.187.217.74
52.34.209.144

@klubar,
Thank you for the additional information.

We can do our best to help you if you provide a presentation and code example reproducing the problem. Unfortunately, at the moment, we do not have enough data to find out the causes of the problem.

@klubar,
I will do some tests and reply to you later.

There are 5 files in this folder:

Basic action of program
Delete old deck (doesn’t exist, but just in case)
Create new file, copying old file
Get info about new file
Merge slides from other files
Get info about file
Text subsitution 1
Text subsitution 2
Text substitution 3
Create PDF output
Create PPTX output

I did 4 runs of my program

Run #1: Commented out substitution and ran to completion
Run #2: Text substitution call #1 and #2 worked, #3 never returned
Run #3: Text substitution call #1 never returned
Run #4: Merge slides call never returned

You can test run this program at:

https://commercial.santanderbank.com/aspose/aspGenerate.php?uid=850

No problem with repeated runs as it generates a new name each time

I will PM you with my ASPOSE credentials so you can look a the files.

The fact that it sometime works (at least to a some step) and sometimes just hangs makes me suspect that it’s not at our end.

In case you could not access the onedrive files, I’ve attached them

For ASPOSE.zip (21.7 KB)

@klubar,
Thank you for the additional data. We will reply to you as soon as possible.

Thanks. Let me know if there is anything I can do to help. This is is now becoming a major issue.

@klubar,
I am already testing the methods you used. I will reply to you later.

Thanks for looking into this.

I don’t know if this is part of your testing, but I just tried my application (at 3:39 PM EST 11/29) and it’s now hanging at step 2:

  1. Delete old deck (doesn’t exist, but just in case)
    2. Create new file, copying old file

Here is the call and response
POST: https://api.aspose.cloud/v3.0/slides/output_2021-11-29_15-37-40_u61a53a1471924.pptx/fromSource?sourcePath=santander\template.pptx&sourceStorage=emiaws&folder=finalDecks&storage=emiaws
Authorization: Bearer eyJhbGciOiJSUzI1NiIsInR5cCI6IkpXVCJ9.eyJuYmYiOjE2MzgyMTgyNjAsImV4cCI6MTYzODMwNDY2MCwiaXNzIjoiaHR0cHM6Ly9hcGkuYXNwb3NlLmNsb3VkIiwiYXVkIjpbImh0dHBzOi8vYXBpLmFzcG9zZS5jbG91ZC9yZXNvdXJjZXMiLCJhcGkuYmlsbGluZyIsImFwaS5pZGVudGl0eSIsImFwaS5wcm9kdWN0cyIsImFwaS5zdG9yYWdlIl0sImNsaWVudF9pZCI6ImU1N2NhZGJmLTA2MTQtNDM3YS1iOTI2LTgwZjkwNGQ3MzBiZiIsImNsaWVudF9kZWZhdWx0X3N0b3JhZ2UiOiJlMDcyZTI2Mi03MzNkLTRjZGQtOTkwNi05YWVmMDI0ZjcyMTciLCJjbGllbnRfaWRlbnRpdHlfdXNlcl9pZCI6IjE2MTcxOSIsInNjb3BlIjpbImFwaS5iaWxsaW5nIiwiYXBpLmlkZW50aXR5IiwiYXBpLnByb2R1Y3RzIiwiYXBpLnN0b3JhZ2UiXX0.S3LmaOTPQTxJIhPoWtE3uzzbIXY6sKwRtjjT8ushMnHP-i6NsjOAdLgjRugwKzPu9XFQ7K1IWblw7cPzpJdThvdqKrj6-FZBGUl62UzQ7CLs_Z3Nq-A3VdDVIbV9skK5t6MPuGEAzpCSK7eq3Cm6bowclWrN5qIzCLZePadb905AiR5lzti92y7QcwCQ67HtXNBFAzZr-Qzy1LX9DfMWl4qdEmMO2xsYGTrGmpSC8CGYphG7_GRHu97xBdPeQw3PiYOjjI7ekMvYSJSmiod6dR_aoybmtrVm4QlMHReg60ygrb5bz3DACU4KzPyfmTBMI13smT7lW2QTs_nOkF0A2Q
x-aspose-client: php sdk v21.9.0

No response from the ASPOSE servers to this request.

This step was working on Friday when I last tested it. I haven’t touched my code.

@klubar,
I added a ticket with ID SLIDESCLOUD-1312 in our issue tracking system. Our development team will investigate these cases. We will inform you of any progress.

It would be great if you could share PHP code examples.

Any update on this? I did a couple of tests yesterday afternoon and this morning (ET) and it seems to be working and much faster.

@klubar,
I have requested some news or plans for this issue from our development team. We will reply to you soon.

@klubar,
Our developers have restarted the container and the problem disappeared. We didn’t detect the root cause so unfortunately, we can’t be sure the problem wouldn’t return. But we have added a periodic job to make test requests and check app health, so at least we will restart the container again as soon as possible.

Thanks for your help in getting this resolved. We are hopeful that the new monitoring system will catch issues like this sooner.

@klubar,
Our development team will do its best to prevent these cases. We apologize for any inconvenience.