We're sorry AsposeCloud doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.cloud

Insert PDF WordPress Plugin issue

Unfortunately, this is not working at all for me.

I tried twice to bring in a 6 MB PDF…

Here is my SID

App SID:875775BC-8A52-49BA-8C65-7F4BDFA6802E

File URL is https://reversemortgageadvisors.net/wp-content/uploads/2022/03/JungoEmailDripCampaigns-ReverseMortgageCampaigns.pdf

Is also available at https://drive.google.com/file/d/10lSHqcKS7bEEfprOMi7HKb2FXi10RHRG/view?usp=sharing

Please let me know if you can assist.

Best,

Ken


This Topic is created by tilal.ahmad using Email to Topic tool.

@kenlyle

It looks like you are getting the issue due to a large PDF and a lower value of max_execution_time in the PHP setting. Please increase its value to 300sec and test the PDF import again. Hopefully, it will help you to resolve the issue.

You can set the max_execuation_time parameter value using any of the following options.

.htaccess

Locate .htaccess file in the same folder as your /wp-content/ and /wp-admin/ folders. Once you locate the file just add this line at the bottom of your .htaccess file and save it.

php_value max_execution_time 300

php.ini

Another option is to fix the maximum execution time exceeded error in WordPress by modifying your php.ini file. The php.ini file is a configuration file that defines settings for PHP on your server. On many WordPress hosting platforms, you may not see it inside your WordPress folder. In that case, you can create a new php.ini file inside your WordPress root folder. After that, edit the php.ini file, add the following line and save it.

max_execution_time = 300

Thanks!

that parameter was at 300, so I set it to 600.

Still, nothing imports. Actually, the only visible text in the HTML that gets entered into the post is like  

I upgraded PHP from 7.4 to 8.1, and the import seemed to run longer…indicated by the 8 section pink “running” wheel…would love to see some kind of feedback…maybe chunking the file in to 1 MB chunks…

Do you know why the Mammoth Docx importer runs so much faster?

The import ran long enough that I searched for airfares for a trip, wrote some emails, etc…it is still running…at least the wait wheel is still spinning…

@kenlyle2

We are sorry for the inconvenience. We have logged a ticket WORDPRESS-454 for further investigation and rectification. We will keep you updated about the issue resolution progress within this thread.