Free Support Forum -

How to create a new Microsoft PowerPoint Presentation using template in azure storage using Aspose.Slides REST API


Problem: I am trying to do PUT request to produce PPTX using template engine and azure storage. I tried this same also with pptx saved as potx with no luck.


Attached file test.xml as body of PUT request gives this error result (it is valid xml document):
400 Client Error: Bad Request
{“Message”:“Unknown file format.”}

Also included attachment test.pptx used as tags parameter in xml.

Template engine described here:

And API example from this page is what i am trying to use:

Storage works ok with other api calls.

Hi Juhana,

Thanks for your interest in Aspose.Slides.

I have observed the issue shared by you and suggest you to please visit this documentation link to serve the purpose on your end. If there is still an issue then please share the working sample project and complete details to reproduce the issue on our end.

Many Thanks,


Thanks but other api calls work just fine with 3rd party storage so maybe this api is broken or does not work with 3rd party storage? So can you please my question how to solve this or if you are going to fix it? All information to preproduce the issue is already there.

Hi Juhana,

I have observed the information shared by you. An issue with ID SAASSLIDES-174 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been lined with the issue so that you may be automatically notified once the issue will be resolved.

We are sorry for your inconvenience,

Any news when this is going to be checked? I have tried same with aspose storage with same error message.

Hi Juhana,

I have verified from our issue tracking system and regret to share that at present the issue is still pending for investigation and has been scheduled for Week 39. We will share the feedback with you as soon as the feedback will be shared by our product team.

Many Thanks,

The issues you have found earlier (filed as SAASSLIDES-174) have been fixed in this update.

This message was posted using Notification2Forum from Downloads module by Aspose Notifier.