We're sorry AsposeCloud doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.cloud

Getting error while running aspose/words-cloud docker image

Hello Aspose support,

We are trying to run https://hub.docker.com/r/aspose/words-cloud docker-image on our aws application using ECR and fargate services. but we get the following Error when calling the API:

“Error”: {

    "Code": "ErrorInvalidInputData",

    "Message": "Can not deserialize string '%PDF-1.4\n%����\n4 0 obj\n<</ColorSpace/DeviceRGB/Subtype/Image/Height 169/Filter/DCTDecode/Type/XObject/Width 1061/BitsPerComponent 8/Length.......

I would like to know if this is possible to run the docker-image on our aws container and how can I get it work?

thanks in advance.

@saharsam6

It seems you already posted a similar query regarding the CompareDocumentOnline API method and we are looking into it. However, if you are getting the above error against some other API, then please share more details along with the code.

Thanks for your answer. It’s the same API as in other post. if I could get a pdf result of comparison of two documents using the aspose/words-cloud Docker image, then my problem would be solved. but currently I’m getting this Error. (I am runinnig it on aws container as explained above.)

another question would be: how can I address my own service via API (aspose/words-cloud Docker image or any other aspose docker image which compares two pdf files with each other and returns a pdf as comparison result)?

Thank you.

@saharsam6

The CompareDocumentOnline API method is working fine in SDKs and Postman but, surprisingly, has some issues in cURL. It looks like there is some issue with my cURL version or the way data fields are processed in cURL. We logged a ticket(WORDSCLOUD-2161) to further investigate the cURL issue.

The first parameter is document, the second is compareData and the third is comparingDocument.

Thank you so much for the answer.

@saharsam6

We have checked the cURL command issue and it seems the DateTime field is causing the problem. However, you can omit the field as following. Hopefully, it will help you accomplish the task. Please note that for Docker, you need to use your (docker)URI instead of aspose.cloud hosted URI.

curl -X PUT "https://api.aspose.cloud/v4.0/words/online/put/compareDocument" 
-H "accept: multipart/mixed" 
-H "Authorization: Bearer eyJhb.....h5JlUovRQxL4BkteQNYZoTKNQ" 
-H "Content-Type: multipart/form-data" 
-F document="@C:/Temp/compareTestDoc1.doc" 
-F compareData="{ \"Author\":\"string\", \"ResultDocumentFormat\": \"doc\"}" 
-F comparingDocument="C:/Temp/compareTestDoc2.doc"