We're sorry AsposeCloud doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.cloud

Getting Bad Request from DELETE REST API for file name containing 'POWERS Hydrate'

Hi

We have observed on 22-July-2021, DELETE REST API call was failing for file name containing ‘POWERS Hydrate’ with 400 status error.
‘Delete’ REST API work for others file names.

We have checked API usage logs and not able to find any ‘Delete’ log entry with 400 status in API usage logs for file name containing ‘POWERS Hydrate’.
Please check the attached, those files were not able to delete via ‘DELETE’ Rest API call.

POWER Hydrate DELETE API Failed.png (16.1 KB)

Please let us know the reason for this issue.

Thanks

@matt.doll

We are investigating the server logs and will share our findings with you asap. Please let us know if you are using some other Client id as well along with cd9477a0-fbf8-44cb-b01a-bebc92630e2c.

Meanwhile, I have renamed a word document to HeaderImageV4_POWERS HYDRATE_OA_92_35343.docx and tested the scenario using Aspose.Words Cloud DeleteFile API. I did not find any issue in deleting the file.

Hi Tilal,

That’s the only client Id that I am using.

It’s working for all other files except the one I mentioned, we are stuck as we could not generate contract file for this customer.

It works with any other name as long as Powers Hydrate is not in the file name, which seems buggy.

While I understand that it worked for you after renaming the file, please let me know why it’s failing in my case?

Matt

@matt.doll

Thanks for your feedback. Kindly share your sample code that you are using for the file deletion and provide your credentials in a private message. We will try to replicate it at our end and will guide you accordingly.

Hi @tilal.ahmad,

We are using Client Id ‘cd9477a0-fbf8-44cb-b01a-bebc92630e2c’

We also tested the same scenario using ‘Aspose.Words Cloud DeleteFile API’ mentioned.

We tried for file name ‘TsysProcessing_POWERS Hydrate_OA-0072185_2021_07_22_06_36_45.docx’.

This is request screen shot attached.
Powers Hydrate Delete REST API Request.png (31.6 KB)

This is respose screen shot attached.
Powers Hydrate Delete REST API Response.png (50.0 KB)

One more thing, we do not want to change file name format. It is essential for bussiness logic.

Please let us know as soon as possible.

@matt.doll

Please remove the leading forward slash in the path, it will resolve the issue.

Hi Tilal,

Today we are getting different error on Aspose portal. These errors are severely affecting our production systems.

How long will this error take to fix?

image.png (172.4 KB)

Matt

@matt.doll

We are sorry for the inconvenience. There was a certificate issue at our server. It is fixed now.

Hi Tilal,

We tried removing the leading forward slash in the path but no luck. Still facing the issue while deleting the file.

For example, I am able to DELETE the following file,
https://api.aspose.cloud/v4.0/words/storage/file/Template/TsysProcessing_Test App_OA-0072267_2021_07_28_03_33_20.docx

but NOT this one,
https://api.aspose.cloud/v4.0/words/storage/file/Template/TsysProcessing_Hula Hoop Nashville_OA-0072267_2021_07_28_03_26_21.docx

It’s a same code, same Aspose credentials, everything is the same except the file name.

Looks like Aspose File delete API is not liking certain words in file name, like Powers Hydrate and Hula Hoop Nashville due to some bug.

Please suggest solution for this.

Matt

@matt.doll

I am afraid the file deletion working fine at my end, without leading forward slash in the file path. As requested above, please share your credentials(Client ID and Secret) in a private message. We need to replicate the issue at our end for investigation.

Furthermore, we have logged a ticket WORDSCLOUD-1692 to investigate the leading forward slash issue in the file path. We will keep you updated about the issue resolution progress.

Hi Tilal,

And I am afraid that Aspose customers like me do not have luxury to use your API test page in production systems. Unfortunately, we have to “code” to integrate with Aspose APIs, and that’s where DELETE call is failing for the files I mentioned earlier.

I have double checked that your API test page “smartly” processes it but the same fails when invoked through code. Try to delete the files that I mentioned by writing the code for it instead of API test page.

Also, API Usage page is not listing any failures. In runtime I am getting 400 response code but don’t see it under API Usage page on Aspose portal!

Matt

@matt.doll

We are sorry for the confusion. We focused on the Swagger API explorer due to your shared screenshots.

Please confirm you are using .NET/Java or some other language for coding. Kindly share your sample code. It will help us to address your issue exactly.

The issues you have found earlier (filed as WORDSCLOUD-1692) have been fixed in this update. This message was posted using Bugs notification tool by Ivanov_John