We're sorry AsposeCloud doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.cloud

Facing Issue with Font in aspose word cloud api

I am facing an issue on font, when i pass the .docx file to “InsertDrawingObjectOnlineRequest” api for inserting an svg. Here I set the footer text with font ‘Calibri [TrueType, Encoding:WinAnsi]’ on the .docx file which i have created. But the output generated from the aspose api showing wrong footer text and font. Please refer to the attachment.

word input template to aspose:
word-template-i-am-using-with-footer.docx (49.9 KB)

word output from aspose:
Cold Spring Harbor Laboratory FCA FCA 10 Year Annual CSP By Category Chart-Admin-11_07_2022_04_17_54.docx (106.2 KB)

pdf output from aspose:
Cold Spring Harbor Laboratory FCA FCA 10 Year Annual CSP By Category Chart-Admin-11_07_2022_06_29_09.pdf (43.3 KB)

Screenshots
Font Issue in Word:
font-issue-in-word.jpeg (128.2 KB)
Font Issue in PDF:
font-issue-in-pdf.jpeg (56.4 KB)

I am eagerly waiting for a solution.
Thank you.

@HPLINC

We are sorry for the inconvenience. We have noticed the font issue in the footer and logged a ticket (WORDSCLOUD-2142) for further investigation and rectification. We will notify you as soon as it is resolved.

hi, whether you able to investigate. what is the status?

@HPLINC

I am afraid the issue is still pending for investigation in the queue, as we have recently noticed the issue. We will notify you as soon as we make some significant progress toward the issue resolution.

1 Like

@HPLINC

We have investigated the issue and it does not seem to be an Aspose.Words Cloud API related issue. As the output has no font issue in the latest MS Word version or in Google Docs, Can you please check the output on the latest version of MS Word or Google Docs and share the results?