We're sorry AsposeCloud doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.cloud

Excel to JSON not working

Hello. Our project uses your API to convert excel files to json (https://api.aspose.cloud/v3.0/cells/convert). Everything worked before. Today, the API began to return an invalid JSON, and besides, it does not return Excel’s hidden pages, although everything worked before. Please tell me why this happened and what are the possible solutions


We will check your issue ASAP.
Could you supply test file for us?
That can help us find and fix the issue faster.

Yesterday, we released Cells Cloud 22.12.
We have done some testing on converting JSON. But we did not reproduce the hidden pages and other issues, please describe the issues you mentioned in detail and post the Excel file here. We go on check it.

The first page does not work (page name: “Общая” (russian lang)), the API returns an erroneous JSON, like “Общая”:, the comma comes immediately after the colon.

hidden pages don’t work either

You can use any file for test

Thank You.

can you roll back a version while testing? we really need a working version of the API, and we can wait a long time for a new update, and besides, this problem is probably not only with us.

We will review the documentation you provided and confirm the solution. But we will give you a temporary solution as soon as possible.

We have deployed the fixed version.
Please try it.