We're sorry AsposeCloud doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.cloud

Create Reports in Integromat / Postman using Aspose.Words Cloud throws error: Can not deserialize string

Hello,
My goal is to execute a report from an uploaded template in Integromat. I tried this URL

https://api.aspose.cloud/v4.0/words/buildReport?documentFileName=result.docx

with parameters data, reportEngineSettings and template in a form data in a HTTP module. As result I got:

ErrorInvalidInputData: Can not deserialize string 'PK …

Therefore I tried the same in Postman and got the same result. I used a form data body with a template element of type file. I thought, that there’s something wrong with the template parameter and tried

https://api.aspose.cloud/v4.0/words/storage/file/test.docx

with parameters fileContent in the same way. This was working fine. I could upload a file. So it seems, that the problem has something to do with the form data. Can someone help me what I am doing wrong here.

best regards
Robert

@Robert_Motzke

I am looking into the issue and will share the update shortly.

@Robert_Motzke
I have tested the BuildReprotOnline API method in postman without any issue. Please check the sample template/data along with the following screenshots. Hopefully, it will help you to accomplish the task.ReportTemplate.docx (11.5 KB)

JSON Data

[{
	Name: "John Doe",
	Age: 30,
	Birth: "1989-04-01 4:00:00 pm"
},
{
	Name: "Jane Doe",
	Age: 27,
	Birth: "1992-01-31 07:00:00 am"
},
{
	Name: "John Smith",
	Age: 51,
	Birth: "1968-03-08 1:00:00 pm"
}]


reportingengingsettings:

 {
  "DataSourceType": "json",
  "ReportBuildOptions": [
    "AllowMissingMembers",
"RemoveEmptyParagraphs"
  ],
  "DataSourceName": "persons"
}

Hello @tilal.ahmad,
Thanks for your reply. I’ve adjusted every settings of my request in Postman as you mentioned. The problem is, that I still have the same result as before. I also tried it with different platforms – same result. I exported a Postman collection with this one request. I would be great if you can have a look on it.
Screen Shot 2021-08-11 at 07.53.53.png (420.0 KB)
Aspose.postman_collection.json.zip (1.7 KB)

best regards
Robert

@Robert_Motzke

Please pass form-data keys in following order i.e. template, data and reportingenginsettings. It will resolve the issue.

Hello @tilal.ahmad,
… now it’s working – thank you very much
best regards
Robert

1 Like