We're sorry AsposeCloud doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.cloud

Converting PPTX to PDF with Notes - API Version Issue?

I’m currently testing aspose.slides capabilities using the supplied cloud docker image.

I’ve tried converting a pptx to pdf including notes. When done using the cloud docker API, only partial notes show up in the PDF - just the first line (title) and none of the following text.
I’ve tried the same conversion using the regular cloud API, and the notes seem to convert fine with all the text.

I noticed the slides API version in the docker is 22.3, and in the actual cloud the version is 22.4.
Is the notes issue a bug that was fixed in 22.4?
If so, when will a docker image with version 22.4 become available? Or is there some way to upgrade to 22.4 in my current docker?

I also noticed the current release version for slides is actually 22.5 (according to release notes), so why is the cloud still reporting version 22.4?

I should also mention that I’ve tried doing the same conversion but to html (not html5) and notes don’t show up at all, no matter what I set for NotesPosition.

@totoguy,
Thank you for contacting support. We will reply to you as soon as possible.

@totoguy,
The Cloud API version is not updated immediately after updating the on-premises library. We need to do some work and testing first. So the update performs later. To investigate this case on our end, please share the following:

  • input presentation file and output files
  • code example that reproduces the problem with notes

I’ve attached a zip with the input and output files when using the local docker cloud api.
This is the curl command used:

url -X POST "http://localhost:3030/v3.0/slides/convert/pdf?fontsFolder=fonts" 
 -F "file=@test.pptx" 
 -F "data=@pdfoptions.json;filename=" 
 -H "accept: multipart/form-data" 
 -o output.pdf

pdfoptions.json content is:
{ "NotesPosition": "BottomFull" }

I’ll mention again that it seems to work fine when using the actual cloud api.

notesissue.zip (245.8 KB)

@totoguy,
Thank you for the additional data. I’ve added a ticket with ID SLIDESCLOUD-1475 to our issue tracking system. Our development team will investigate this case. You will be notified when the issue is resolved.

@totoguy,
Our developers investigated the issue. The notes are truncated in evaluation mode. You have to obtain a metered license to use the Slides Cloud docker images in the full-featured mode.

Documents: Pricing Plan