We're sorry AsposeCloud doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.cloud

Convert PDF XFA form to Acro form returns Corrupted file

When I use the endpoint https://api.aspose.cloud/v3.0/pdf/convert/xfatoacroform?outPath=result2.pdf even with the sample provided on the documentation https://docs.aspose.cloud/pdf/convert-xfa-based-pdf-forms-to-pdf-with-acroform/ the PDF result is corrupted and not able to open it ( tried in chrome and Adobe Reader).

To download I’m using https://api.aspose.cloud/v3.0/pdf/storage/file/result2.pdf
Any idea what I could be wrong?

@webmathias

Please share your input document with us. We will test the scenario and will share our findings with you.

Sure, the File that I tried was the one found on the documentation: https://docs.aspose.cloud/pdf/convert-xfa-based-pdf-forms-to-pdf-with-acroform/PdfWithXfaForm.pdf

@webmathias

Thanks for sharing the additional information. We have noticed the reported issue with the referenced PDF document. So logged a ticket(PDFCLOUD-2546) in our issue tracking system for further investigation. We will keep you updated about the issue resolution progress.