Free Support Forum - aspose.cloud

Compare MS Word Documents with track changes enabled using Aspose.Words REST API throws Internal Server Error

I’m trying to use the compare feature, and I’m getting “Internal Server Error” with my sample documents.

On further inspection, this only happens when the documents have track changes enabled. I tried using sample code and documents from an Aspose directory, which worked fine - but if I open one document in MS Word, enable Track Changes, make one change, save the document, and try Aspose Compare again - poof, Internal Server Error.

There is no documentation that suggests Track Changes in compared documents are not supported, and I’d expect the feature to work similar to MS Word’s Document Compare, which accepts all existing Track Changes before doing the comparison. There is no Aspose documentation that talks about what happens with existing Track Changes, either.

What’s the expected behaviour here? Should Aspose compare documents with track changes used?

@bmulhollandrecital

Please note the compared documents should have not revisions. Before comparing the documents, you need to accept or reject the revisions. Please use Revisions APIs for accepting and rejecting the revisions and then compare the documents. If you still face any issues then kindly share your input document with us. We will investigate the issue and will guide you.