We're sorry AsposeCloud doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.cloud

Aspose.Words Exporter WordPress Plugin activation error by woocommerce

I can’t activate the plugin, i receive this error:

[06-Aug-2021 19:41:28 UTC] wc_get_product was called incorrectly. wc_get_product should not be called before actions have not completed woocommerce_init, woocommerce_after_register_taxonomy y woocommerce_after_register_post_type. Backtrace: require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘init’), WP_Hook->do_action, WP_Hook->apply_filters, WooCommerce->init, wc_load_cart, WooCommerce->initialize_cart, WC_Customer->__construct, WC_Data_Store->read, WC_Customer_Data_Store->read, WC_Data->read_meta_data, maybe_unserialize, unserialize, WC_Data->__wakeup, WC_Product_Variation->__construct, WC_Product_Simple->__construct, WC_Product->__construct, WC_Data_Store->read, WC_Product_Variation_Data_Store_CPT->read, WC_Product_Variation_Data_Store_CPT->generate_attribute_summary, wc_get_formatted_variation, wc_attribute_label, wc_get_product, wc_doing_it_wrong. This message was added in version 3.9.

@Routerpar

We are sorry for the inconvenience. We will appreciate it if you please confirm your PHP, WordPress and Aspose.Words Exporter version. We will try to reproduce the issue at our end and investigate it.