Aspose.Words Cloud self-hosted Docker Instances Stopped Working

We’ve been running self-hosted containers of words-cloud for about one year now. All of a sudden today we’re seeing the Aspose watermark start showing up in files. According to our account manager, the license is still vaild until February 18, 2024 (Reminder, that it is February 13, 2024 today).

Furthermore, new instances fail to start with:

Application startup exception: System.InvalidOperationException: Authentication failed.

We’re running 24.1 and also confirmed that we’re facing the same issue with 23.12.

Why are our containers running in trial mode all of a sudden when our license is still active? Our account manager confirmed that our account management page shows the license as active (It is a metered license). We have not changed our infrastructure nor deployment for several weeks.

Please assist us as immediately as this is affecting our production environment.


@tilal.ahmad We’ve obtained your paid support services and followed up with a help desk ticket for this issue two hours ago. We have not received a response yet. Please have someone respond immediately and address this issue with your service as soon as possible as it’s affecting our production environment.

We have also confirmed with an Aspose account representative shortly after this incident started today that our license is still valid. We should not be dealing with watermarks in our documents, nor the inability to start new instances with a paid valid license.


We apologize for the inconvenience. Our team is currently investigating the issue and will provide you with an update soon.

@james-ontra Hi, we are experiencing the exact same issue. Did you have any luck getting it resolved yet?

@james-ontra If it can help you: reverting to version 23.1 solves the issue for me.

1 Like

HI @akellens thank you for the suggestion, we’re going to try downgrading to 23.1 today (I work with @james-ontra).

@mcummings In the meantime I did some more testing, and it appears that version 23.10 is still safe to use. From 23.11 onwards the bug occurs.


@akellens thank you for the update! We haven’t rolled back yet (actually we tried 23.12 last night to no avail) to 23.1 but if 23.10 looks good, that would work much better for us, until Aspose fixes the issue.

hello @akellens, we downgraded to 23.10 but we’re still seeing the same issue

System.InvalidOperationException: Authentication failed.    at Aspose.Words.Metered.SetMeteredKey(String publicKey, String privateKey)    at Aspose.Words.Cloud.LicenseInitializer.InitMeteredLicense(String , String )    at Aspose.Words.Cloud.WebApp.Startup.InitLicense() in C:\Build\src\Aspose.Words.Cloud.WebApp\Startup.cs:line 258    at Aspose.Words.Cloud.WebApp.Startup.Configure(IApplicationBuilder app, IWebHostEnvironment env) in C:\Build\src\Aspose.Words.Cloud.WebApp\Startup.cs:line 240    at System.RuntimeMethodHandle.InvokeMethod(Object target, Span`1& arguments, Signature sig, Boolean constructor, Boolean wrapExceptions)    at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)    at Microsoft.AspNetCore.Hosting.ConfigureBuilder.Invoke(Object instance, IApplicationBuilder builder)    at Microsoft.AspNetCore.Hosting.ConfigureBuilder.<>c__DisplayClass4_0.<Build>b__0(IApplicationBuilder builder)    at Microsoft.AspNetCore.Hosting.ConventionBasedStartup.Configure(IApplicationBuilder app)    at Microsoft.Extensions.DependencyInjection.AutoRegisterMiddleware.<>c__DisplayClass4_0.<Configure>b__0(IApplicationBuilder app)    at Microsoft.AspNetCore.Mvc.Filters.MiddlewareFilterBuilderStartupFilter.<>c__DisplayClass0_0.<Configure>g__MiddlewareFilterBuilder|0(IApplicationBuilder builder)    at Microsoft.AspNetCore.HostFilteringStartupFilter.<>c__DisplayClass0_0.<Configure>b__0(IApplicationBuilder app)    at Microsoft.AspNetCore.Hosting.WebHost.BuildApplication()

Any word on when this might get mitigated?

hi @akellens so sorry, I thought you worked for Aspose. Thanks for your help on this issue. Hopefully they fix the bug soon :crossed_fingers:


We have fixed the issue. Please try now Aspose.Words Cloud Docker Image 24.1 and confirm. However, if the issue persists, then please share your public and private key via a private message for further investigation.

thank you @tilal.ahmad, we were able to update & resolve the issue.


We appreciate your feedback. We are glad to hear that your issue has been resolved.