Free Support Forum -

Aspose Cloud API is throwing 400 Bad Request error with incorrect credit usage details


As of today I am receiving 400 Bad Request responses from any API call that I try to make. When I look at my history, it appears that it has to do with my pricing plan. However, I am sure that I have not reach my limit since the monthly renewal (today). The error itself also indicates that I have not done 2500 API calls, but only 4.

I even tried to upgrade my account to an account with a higher limit, but I still receive the same issue.

Does anyone have a clue why this is happening and how I can continue using Aspose for Cloud?

Thank you in advance.

Kind regards,


Hi Robin,

We became aware of an issue affecting URL Signing for customers using our PHP/Ruby customers due to an issue within the SDK and believe this issue may be related. That issue is now resolved.

Can you confirm if you are still having any issues?


Sorry for my late response.

The issue is indeed solved.

Thank you for your quick response.

Regards, Robin