The data is hidden in result convert pdf


#1

Hi Aspose’s Support,

I have converted Excel to Pdf as following sample :
http://www.aspose.com/docs/display/cellscloud/Convert+Excel+Workbook+with+Additional+Settings
with following steps :

Step 1 : Upload excel file to Aspose’s server (ex : sample-OUT.xlsx)
Step 2 : Convert excel file into result PDF (ex : sample-OUT.pdf)
( String strURI = “http://api.aspose.com/v1.1/cells/excel.xlsx/saveAs?newfilename=sample-OUT.pdf”; )
Step 3 : Download result PDF file (using GET method)

The PDF Save Options :


true

true

false
None
500

100

false

Pdf



I can see that the data line : - what.is.it@test.com is hidden in convert pdf file although I can select it and copy it’s content. I don’t know what’s wrong with it.

+ In file Excel :


+ In file convert pdf :


Thanks,
Chien


#2

Hi Chien,

Thank you for sharing the sample spreadsheet.

I have evaluated the presented scenario while using the following PDF settings and URI, however, I am not able to replicate the said issue on my side. Please note, the first letter of the boolean type values in the XML should be capital, as demonstrated below. Please give these settings a try on your side. In case the problem persists, please confirm if you are manipulating the spreadsheet in any way before rendering it to PDF. It is preferable that you should share a sample console application to replicate the said issue on our side.

string xml = @"
True
True
False
None
500
100
False
Pdf
";

string remoteFile = “sample-OUT.xlsx”;
string strURI = “http://api.aspose.com/v1.1/cells/” + remoteFile + “/saveAs?newfilename=output.pdf”;

#3

Hi Babar,

I have tested the issue again based on your suggestion of PDFOptions and it’s OK now.
Thanks a lot.

Best Regards,
Chien


#4

Hi,

Thanks for your feedback and using Aspose.Cells.

It is good to know that your issue is resolved with the latest fix. Let us know if you encounter any other issue, we will be glad to look into it and help you further.


#5

Hi Babar,

With your suggestion about PDFSaveOptions, the issue has been resolved but I have got two of following problems :
1. The output pdf is always in one page with the setting
False
2. The formula is not process with the setting
True
(You can see the attachments)

With my old settings, it works fine :
false
=> show multi page as in Print Preview of Excel Spread Sheet
true
=> only show 1 page

true
=> Process calculating formula

Please give me a suggestion about it. Thanks.

Moreover, I had got a lot of errors in converting pdfs (in Step 2) with time following time ranges :
29/Aug : from 16:56 GMT+07 to 23:37 GMT+07 (30 items)
30/Aug : from 00:39 GMT+07 to 10:09 GMT+07 (100 items)
=> Have the Aspose’s server got any problems ?

Step 1 : Upload excel file to Aspose’s server (ex : sample-OUT.xlsx)
Step 2 : Convert excel file into result PDF (ex : sample-OUT.pdf)
( String strURI = “http://api.aspose.com/v1.1/cells/excel.xlsx/saveAs?newfilename=sample-OUT.pdf”; )
Step 3 : Download result PDF file (using GET method)

Best Regards,
Chien


#6

Hi Chien,


Thank you for writing back.

We are looking into your recently shared scenario and we will shortly get back with updates in this regard.

#7

Hi,

Thanks for your posting and using Aspose.Cells for Cloud.

Your settings are right. Please use small Boolean values like true instead of True or false instead of False.

We have also updated the documentation article relating to this issue. Have a good day.

( http://www.aspose.com/docs/display/cellscloud/saveAs+(Controller+resource) )


#8

Hi Shakeel,

Thank you for your response. I think my old codes are suitable for your suggestion. And the original issue still remain : The data is hidden in result convert pdf. I have try on PDFOptions :

false

or
true


but the result pdf file is not good.

+ In Excel file :


+ In PDF file :


Thanks,
Chien


#9

Hi,

Thanks for your posting and using Aspose.Cells.

It is working fine at my end. Will you please try again? I used the same settings as yours. However, I renamed your file to sample.xlsx. I have also attached the output pdf generated by the following REST API for your reference.

POST
http://api.aspose.com/v1.1/cells/sample.xlsx/saveAs?newfilename=output.pdf


true
true
false
None
500
100
false
Pdf


However, this could be the issue of AutoFitRows, so you should try adding the following in the url.

&isAutoFitRows=true

Check this resource URL

( http://www.aspose.com/docs/display/cellscloud/saveAs+(Controller+resource) )


#10

Hi,

Thanks for your posting and using Aspose.Cells for Cloud.

Please also see the above post.

( http://www.aspose.com/community/forums/permalink/772118/774037/showthread.aspx#774037 )

For your following issue.

tdchien:

Please give me a suggestion about it. Thanks.

Moreover, I had got a lot of errors in converting pdfs (in Step 2) with time following time ranges :
29/Aug : from 16:56 GMT+07 to 23:37 GMT+07 (30 items)
30/Aug : from 00:39 GMT+07 to 10:09 GMT+07 (100 items)
=> Have the Aspose’s server got any problems ?


We have investigated this matter and this was our findings.


On our side during that time ranges we couldn’t find issues with Aspose Server. We have successful logs, but the failing logs from user we couldn’t find them. Maybe it was a network related issue on his side but for sure our server worked fine since we have successful logs



#11

Hi Shakeel,

Thank you for helpful information.

I have just tested it again with removing &isAutoFitRows=true and the result is OK. So as you mention, I think this is the issue of AutoFitRows option.

Thanks,
Chien


#12

Hi Chien,

Thank you for the confirmation. We are too able to notice the said problem with isAutoFitRows parameter set to true. We are currently in discussion with the product team team on this matter, and we will shortly get back with updates in this regard.


#13

Hi again,


This to inform you that we have logged this incident in our bug tracking system as CELLSCLOUD-10007 for further investigation & correction. Please spare us little time to properly analyze the scenario and revert back with updates in this regard.

#14

Hi Chien,


Thank you for your patience with us.

Please note, we have resolved the problem logged earlier as CELLSCLOUD-10007. I have tested the scenario using the following URI & XML whereas the resultant PDF is attached here for your reference.

URI
http://api.aspose.com/v1.1/cells/" + remoteFile + "/saveAs?newfilename=output.pdf&isAutoFitRows=true

XML
<span class=“kwrd” style=“font-family: “Courier New”, Consolas, Courier, monospace; font-size: small; white-space: pre;”><<span class=“html” style=“font-family: “Courier New”, Consolas, Courier, monospace; font-size: small; white-space: pre;”>PdfSaveOptions<span class=“kwrd” style=“font-family: “Courier New”, Consolas, Courier, monospace; font-size: small; white-space: pre;”>><span style=“background-color: rgb(255, 255, 255); font-family: “Courier New”, Consolas, Courier, monospace; font-size: small; white-space: pre;”>
<CalculateFormula>true</CalculateFormula>
<EnableHTTPCompression>true</EnableHTTPCompression>
<CreateDirectory>false</CreateDirectory>
<Compliance>None</Compliance>
<desiredPPI>400</desiredPPI>
<jpegQuality>95</jpegQuality>
<OnePagePerSheet>false</OnePagePerSheet>
<SaveFormat>Pdf</SaveFormat>
</PdfSaveOptions>

#15

The issues you have found earlier (filed as CELLSCLOUD-10007) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.