Slow Response time for Slides REST API


#1

Hello,

We have been seeing rather critical response time issues with relatively simple requests to the Slides API via the Ruby SDK. A request to copy a slide from one presentation to another, for example, is taking over 1 minute:

D, [2018-10-19T20:24:33.844901 #53647] DEBUG – : ETHON: performed EASY effective_url=http://api.aspose.com/v1.1/slides/cff1cf5711950a44d2f764c25d0aec77.pptx/slides?slideToCopy=24&source=master_presentations/3/built_presentations/9/temp—cff1cf5711950a44d2f764c25d0aec77.pptx&position=14&folder=master_presentations/3/built_presentations/9&storage=storage-staging&appSID=02e41089-5cc9-49c6-911b-7e381e62c860&signature=04DEAo1Gsx8vAyKjreJ74zis3sk response_code=200 return_code=ok total_time=72.347368

We routinely will need to copy up something like 40-60 slides between decks, but having an 1+ hour response time to do so is not acceptable for our clients.

Can we narrow down the particular issue? Is it the request itself that is slow, are requests on a queue system on your end? Is the process of copy/pasting slides, or requesting slide thumbnails, something that should take 1+ minute per slide?

We were having response times closer to 10-20seconds earlier this week, with smaller powerpoint files, but even that was as slow as we were willing to manage.


This Topic is created by sohail.aspose using the Email to Topic plugin.


#2

@vikaswadhwaextendmed

We are sorry for the inconvenience caused. But unfortunately, we are unable to reproduce the issue on our end.

Would you please test POST /slides/{name}/slides API on the API Reference page and let us know if you are experiencing the same slow response.

Moreover, please provide us with the sample file with which you are experiencing one-hour response time, it may help us in reproducing the issue on our end.

We have marked this thread private, only you and Aspose Staff have access to this thread.


#3

Hello,

I’m not able to provide the file at this time, since it is proprietary, but the issue is that EACH SLIDE, copying from one presentation to another, is taking at LEAST 20 seconds, often taking LONGER than 60 seconds, and I need to know if this is somehow the expected response time.

The two files are exact copies to start, and then individual slides are copied from one to the other. They are both approximately 55MB, but our clients may upload files hundred of MB. The number of slides is approximately 140, but our clients may upload files up to 200 slides.

I have tested the API reference page endpoint at the following URL and yes, I am having the same slow response time of 60+ seconds (I have removed the appsid and signature) :

https://api.aspose.cloud/v1.1/slides/4e21cd74fd1e998c529fa4406e0fe4ff.pptx/slides?slideToCopy=20&position=16&source=development/master_presentations/10/built_presentations/53/dummy---4e21cd74fd1e998c529fa4406e0fe4ff.pptx&folder=development/master_presentations/10/built_presentations/53&storage=Filesystem


#4

Also testing the same endpoint, I am getting repeated responses of 400 with response body

{
“Message”: “Out of memory.”
}


#5

I have been testing further, and it seems the response times are directly related to the size of the powerpoint file.

A 1-2MB file returns a result around 6-10 seconds, while the same action performed on a 55MB file takes 60-90 seconds. I’ve also tried on both the local File Storage provided by aspose and our S3 bucket, with similar results.

Also, if I try to run multiple actions in a row on the same file, if it is on the local File Storage provided by aspose, I receive multiple Out Of Memory issues, which means I have to retry the API call.

Is this expected behavior?


#6

@vikaswadhwaextendmed

Yes, the size of the document does matter. Similarly, the size of the slide that is being copied is also mattered.