Issues with extremely large csv imports to cloud cells


#1

For your cloud product, I’m having issues with the CSV import of extremely large documents via the API. (970k rows, 15 columns) The CSV file is about 130MB. Is there anything that can be done about this? On the admin console, it shows the file, but fails to download.

Thanks!

Trent


#2

Actually, I’m pretty sure it is not even making it to the import phase of the code. I think this is an issue with an upload to the cloud storage. I can provide an example by email if needed. What is the maximum file size supported for the upload?


#3

@trent.bean

Are you able to import smaller CSV file? May be this issue is occurring with CSV of all sizes? If you are able to import smaller CSV file and bigger are causing the issue, then share with us your sample code as well as your CSV file causing the issue. We will look into it and help you asap.


#4

Importing smaller files works just fine. The same report limited to 250k rows uploads just fine and takes about 4 minutes to generate.


#5

@trent.bean

Thanks for providing further information and considering Aspose.

You have mentioned two problems.

1 - Large CSV file does not get uploaded.
2 - Large CSV file does not get imported.

Please clarify, do you have upload issue or import issue? Please also provide us your sample CSV file causing you this issue. Please upload it somewhere like Dropbox or Google Drive etc. and provide us the download link. Thanks for your help.

FYI:

If you like, you can make this Topic private by editing the very first post in this thread and checking the Private Topic checkbox.