Free Support Forum - aspose.cloud

Word to PDF convert Issue


#1

Hi,
while converting a word to pdf using the cloud api the word auto numbering are reversed.
the document is set with hebrew language and right to left orientation.
this functionality worked using the same api in version Aspose.PDF for .NET 18.9 but fails in version Aspose.PDF for .NET 18.10.

the word file and the PDF output are attached.Test.zip (70.9 KB)

Thanks,
Tsafrir


This Topic is created by sohail.aspose using the Email to Topic plugin.


#2

@operationsdotbcs

It may be because the font used in the document does not exist in our server. Please upload the missing font to Aspose Cloud Storage under a particular folder and then specify the name of the folder as a value to the fontsLocation parameter.

A pictorial description is given here Noticed text style changes in the produced PDF file.

Please let us know if the issue still not fixed.


#3

the same font was used in version 18.9 and worked.
the font is displayed correctly it is just an issue of Left-to-Right alignment of the numbering.
what was changed in version 18.10??


#4

@operationsdotbcs

Would you please confirm are you using Aspose.Words REST API PUT /words/convert to convert Word document to PDF? or are you using Aspose.PDF Native APIs?


#5

Hi,
yes this is the REST API we are using.
Thanks,
Tsafrir


#6

@operationsdotbcs

Thanks for clarifying it. We are working to fix the issue (WORDSCLOUD-660) at the earliest.