Free Support Forum - aspose.cloud

Rest API v1.1 - Receiving 400 response. RTF -> PDF

Hi,


We are having issues during the conversion process from RTF to PDF. Our conversion is done in batches, so multiple requests are sent to the cloud API.

The problem we are seeing is during some rest request we are getting 400 response (Bad Request), for about 10% of the RTFs in the batch. If we attempt to reconvert the failed files again, without changing request, we are successful. It does not seem that 400 are the correct responses, to our requests. Any insight in to this issue would be much appreciated.

Thanks,
-Ivan


Hi Ivan,

Sorry for the inconvenience.

Can you please share which operating system and development language/platform are you using?

Best Regards,

Hi,


Sorry for the delayed response.

We are using Java and Spring’s RestTemplate to make the requests to Cloud API. It seems that no matter what the error on the API side is, the response is always 400.

Could you elaborate on the possible response codes that API could respond with.

Thanks,
-Ivan

Hi Ivan,

HTTP error 400 means there was some issue with the URI or signature and Aspose for Cloud did not entertain this request. In case of Aspose for Cloud errors, you should see proper error messages.

Can you please share your signed URI for further analysis? Please also share your App SID and App Key by clicking my name from the left panel of this post and then selecting 'Send Muhammad Ijaz a private message' options from the options panel.

Best Regards,

Private message sent with details.

Thanks,
-Ivan

Hi Ivan,

Sorry, I have not received these details yet. Can you please try again or send these details to me at Muhammad.ijaz@aspose.com

Best Regards,

Hi Ivan,

Can you please try again and let us know if you still see this issue?

Best Regards,

Hi Muhammad,


We are currently executing the process hourly with small number of conversions (1-4). If I see any more errors I will let you know.

Thank you, for your help on this matter.

-Ivan

Hi Muhammad,


We have been getting the errors again, especially the last couple of days.

Thank you,
-Ivan

Hi Ivan,

Sorry for the inconvenience. The issue was fixed and you should not see this issue now. Can you please share when you last noticed this issue?

Best Regards,

Hi Muhammad,


We had a big spike on Tuesday (4/15 20:43 UTC) about 20 conversions failed. The last error we had was on 4/18 20:42 UTC.

Thanks,
-Ivan

Hi Ivan,

The issue is fixed. Please check my last mail for a detailed reply.

Best Regards,