Free Support Forum - aspose.cloud

FormField post API not working from Cloud API Reference


#1

I have 4 form Field for my word document and I was trying to update the “TextInputDefault” value for second form field by using formField POST api. When i hit the api it show me that value is updated in the response but when i hit the get api for formField then it show me previous value.

I am using the following api
(https://apireference.aspose.cloud/words/#!/FormFields/PostFormField)

parameter list

name: smiley_text.docx
formField: {
“Name”: “fieldname2”,
“TextInputType”: “Regular”,
“TextInputDefault”: “dhbdhd”,
“TextInputFormat”: “UPPERCASE”,
}
index: 1

respose :-1:

{
“FormField”: {
“NodeId”: “0.4.0”,
“Name”: “fieldname2”,
“Enabled”: true,
“StatusText”: “”,
“OwnStatus”: false,
“HelpText”: “”,
“OwnHelp”: false,
“CalculateOnExit”: false,
“EntryMacro”: “”,
“ExitMacro”: “”,
“TextInputFormat”: “UPPERCASE”,
“TextInputType”: “Regular”,
“TextInputDefault”: “dhbdhd”,
“MaxLength”: 30,
“link”: {
“Href”: “http://api.aspose.cloud/v1.1/words/smiley_text.docx/sections/0/paragraphs/3/formfields/0”,
“Rel”: “self”,
“Type”: null,
“Title”: null
}
},
“Code”: 200,
“Status”: “OK”
}

Response in Get form field api after update the form field

{
“FormFields”: {
“List”: [
{
“NodeId”: “0.1.0.0.0.1”,
“Name”: “fieldname1”,
“Enabled”: true,
“StatusText”: “”,
“OwnStatus”: false,
“HelpText”: “”,
“OwnHelp”: false,
“CalculateOnExit”: false,
“EntryMacro”: “”,
“ExitMacro”: “”,
“TextInputFormat”: “”,
“TextInputType”: “Regular”,
“TextInputDefault”: “”,
“MaxLength”: 0,
“link”: {
“Href”: “http://api.aspose.cloud/v1.1/words/smiley_text.docx/sections/0/tables/0/rows/0/cells/0/paragraphs/0/formfields/0”,
“Rel”: “self”,
“Type”: null,
“Title”: null
}
},
{
“NodeId”: “0.4.0”,
“Name”: “fieldname2”,
“Enabled”: true,
“StatusText”: “”,
“OwnStatus”: false,
“HelpText”: “”,
“OwnHelp”: false,
“CalculateOnExit”: false,
“EntryMacro”: “”,
“ExitMacro”: “”,
“TextInputFormat”: “”,
“TextInputType”: “Regular”,
“TextInputDefault”: “”,
“MaxLength”: 0,
“link”: {
“Href”: “http://api.aspose.cloud/v1.1/words/smiley_text.docx/sections/0/paragraphs/3/formfields/0”,
“Rel”: “self”,
“Type”: null,
“Title”: null
}
},
{
“NodeId”: “0.6.0”,
“Name”: “fieldname3”,
“Enabled”: true,
“StatusText”: “”,
“OwnStatus”: false,
“HelpText”: “”,
“OwnHelp”: false,
“CalculateOnExit”: false,
“EntryMacro”: “”,
“ExitMacro”: “”,
“TextInputFormat”: “”,
“TextInputType”: “Regular”,
“TextInputDefault”: “”,
“MaxLength”: 0,
“link”: {
“Href”: “http://api.aspose.cloud/v1.1/words/smiley_text.docx/sections/0/paragraphs/5/formfields/0”,
“Rel”: “self”,
“Type”: null,
“Title”: null
}
},
{
“NodeId”: “0.7.0”,
“Name”: “fieldname4”,
“Enabled”: true,
“StatusText”: “”,
“OwnStatus”: false,
“HelpText”: “”,
“OwnHelp”: false,
“CalculateOnExit”: false,
“EntryMacro”: “”,
“ExitMacro”: “”,
“TextInputFormat”: “”,
“TextInputType”: “Regular”,
“TextInputDefault”: “”,
“MaxLength”: 0,
“link”: {
“Href”: “http://api.aspose.cloud/v1.1/words/smiley_text.docx/sections/0/paragraphs/6/formfields/0”,
“Rel”: “self”,
“Type”: null,
“Title”: null
}
}
],
“link”: {
“Href”: “http://api.aspose.cloud/v1.1/words/smiley_text.docx/formfields”,
“Rel”: “self”,
“Type”: null,
“Title”: null
}
},
“Code”: 200,
“Status”: “OK”
}

Can you please let me know what i am missing during api call?


#2

@arunkamboj

Thanks for your inquiry. We have tested the scenario and noticed the reported issue. We are further investigating the issue and will share the update soon.


#3

@tilal.ahmad Thanks, I am waiting for the update.


#4

@arunkamboj

We have noticed the issue in POST API of formfield and logged a ticket WORDSCLOUD-709 in our issue tracking system for rectification. We will notify you as soon as it is resolved. We are sorry for your inconvenience.


#5

@tilal.ahmad Thank you


#6

@tilal.ahmad Do you have any update for the same?


#7

@arunkamboj

Thanks for your inquiry. Hopefully, if everything goes as per plan, then the fix will be available in release of April 2019. However, please note it is not a promise but we will try our best to include the fix in said version. We will notify you as soon as issue is resolved and gets available in the Aspose.Words Cloud API.

Thanks for your patience and cooperation.


#8

Is there any other older version where i can use form field cloud api?


#9

@arunkamboj

I am afraid you need to wait for the next release of Aspose.Words Cloud API for the fix.