Free Support Forum - aspose.cloud

Error while get files in folder 'Fonts' from storage


#1

Hello Aspose Team,

We are getting the following error message when we specify a directory for fontsLocation:

"“Error while get files in folder ‘Fonts’ from storage: AmazonS3 exception: Object is not exists. Bucket 'afc-”

However, we already have the directory created and a couple of fonts are uploaded there, we had this working but we started to face the error newly.

What would be the issue with this feature?


#2

@Softwareselskabet

We are sorry for your inconvenience. Please share which API method are you using? We will investigate it and will guide you accordingly.

Furthermore, please double check whether font folder still exists or not. Sometimes it is deleted automatically because of Aspose Cloud Storage settings. It clears the storage as per selected storage mode. Paid customers have options to specify folder names to exclude from the automatic deletion. This setting will help you to avoid font folder deletion issue.


#3

@tilal.ahmad Thanks for your reply.

Yes, we have already checked the folder and it’s there.

As for the API method we are using “PostDocumentExecuteMailMergeRequest” and “PostDocumentSaveAsRequest” via the PHP Words SDK.

Also, we have added the “Fonts” folder to be excluded from the deletion.

image.png (12.0 KB)


#4

@Softwareselskabet

Thanks for your feedback. I have tested the document conversion scenario with sample document and fonts, but unable to notice the issue. I will appreciate it if you please share a problematic document along with the referred fonts here. We will further investigate the issue and will guide you accordingly.


#5

@tilal.ahmad we checked this further and we noticed that the issue take place only locally and not on the staging/production servers; however we have this setup for a long time and we started to face this issue newly. Could it be related to request timeout fetching the font with AWS along with some changes took place recently at your side?


#6

@Softwareselskabet

Thanks for your feedback.

No, we have not made any changes in V1.1 API version. However, we have recently released an improved API version 4. We have also released updated PHP SDK for V4 version.

Furthermore, I’m afraid we cannot suggest you anything without replicating the issue at our end. Please share your sample code along with source document and fonts to replicate the issue at our end. Please also confirm your email id linked to your account. We will check the server logs against your account.