Free Support Forum - aspose.cloud

Authentication failed! error when uploading


#1

Hello,

When uploading a word document using the storage API it returns an “Authentication failed!” error message.

I’m using the SDK to send the request. I had to rebuild it myself as it was not strongly named (As per https://forum.aspose.com/t/strong-name-for-aspose-words-cloud-references/162606/3) however other then to add the string name key signing I have not made any changes to it.

I have attached the capture from the Fiddler monitoring tool to capture the output. AuthenticationError.zip (19.7 KB)

Can you please clarify why I am getting this error. I have already confirmed that the app key and SSID match the one shown in my cloud dashboard.


#2

@mstride

Thanks for your inquiry. Please note Aspose.Words for Cloud does not allow special characters in signature URL at the moment. So please double check that your file names should not contain any special characters. Furthermore, if you are not passing some value of versionId and storage to storage API then pass null values for these parameters instead of empty strings. Hopefully it will resolve the issue.


#3

We also receive {“Message”:“Authentication failed!”} on some of our API calls. This has nothing to do with our API keys, as >99% of the API calls are ok.

In other words, there is a bug in the authentication in some edge cases. The timestamps on when this error did happen for us:

  • 5/8/2019 05:59
  • 5/10/2019 01:38

#4

@rvanlaak

Can you please share some more details about the API calls? Apparently, it seems some issue with the specific request URL.